题目
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
思路
找众数,简单写法是对每个元素计数,当某个元素出现次数大于等于n/2时即可认定其为众数(题目保证众数存在)。
也可以转化为找中位数,中位数即是众数,平均复杂度能降低一些,但写起来麻烦点。参考:找第k小数和中位数算法——快速排序思想,复杂度O(n) C++实现
代码
#include <iostream>
#include <unordered_map>
using namespace std;
int main(){
int n, m;
scanf("%d %d", &n, &m);
int len = n * m;
unordered_map<int, int> mmap;
for (int i=0; i<len; i++){
int temp;
scanf("%d", &temp);
mmap[temp]++;
if (mmap[temp] >= len/2){
cout << temp << endl;
break;
}
}
return 0;
}