PAT甲级真题 1055 The World's Richest (25分) C++实现(数组排序,测试点超时问题)

news/2024/5/19 23:07:35 标签: leetcode, 排序算法, 数据结构, 快速排序, 算法

题目

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=10 ^ 5) – the total number of people, and K (<=10 ^ 3) – the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) – the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output “None”.
Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

思路

直观的思路是,建立关于人的结构体数组,按财富值、年龄、姓名的优先级总体排序。每次查询都遍历该数组,输出前m个符合条件的即可。

测试点1用g++编译器有时会超时,换成clang++编译器总能通过(新技能get):
在这里插入图片描述
这个方案最坏情况复杂度是O(kn)。

柳神的方法做了一些预处理。对整个数组排序后,若某个年龄出现次数超过100次,则后面的不做考虑,因为M最大为100,在财富值相等或递减的情况下,不可能输出同一个年龄100名以后的。

代码

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct Person{
    string name;
    int age;
    int worth;
};

bool cmp(Person &p1, Person &p2){
    if (p1.worth==p2.worth){
        if(p1.age==p2.age){
            return p1.name < p2.name;
        }
        return p1.age < p2.age;
    }
    return p1.worth > p2.worth;
}

int main(){
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n, k;
    cin >> n >> k;
    vector<Person> p(n);
    for (int i=0; i<n; i++){
        cin >> p[i].name >> p[i].age >> p[i].worth;
    }
    sort(p.begin(), p.end(), cmp);
    for (int i=0; i<k; i++){
        int m, l, h;
        cin >> m >> l >> h;
        cout << "Case #" << i+1 << ":" << endl;
        int count = m;
        for (int j=0; j<n && count>0; j++) {
            if (p[j].age>=l && p[j].age<=h){
                cout << p[j].name << " " << p[j].age << " " << p[j].worth << endl;
                count--;
            }
        }
        if (count==m){
            cout << "None" << endl;
        }
    }
    return 0;
}


http://www.niftyadmin.cn/n/905833.html

相关文章

cf519D. A and B and Interesting Substrings(前缀和)

题意 给出$26$个字母对应的权值和一个字符串 问满足以下条件的子串有多少 首尾字母相同中间字母权值相加为0Sol 我们要找到区间满足$sum[i] - sum[j] 0$ $sum[i] sum[j]$ 开$26$个map维护一下$sum$相等的子串就可以 /**/ #include<iostream> #include<cstdio> #i…

matlab提取电压基波分量,有源电力滤波器三种基波提取方法的对比分析

随着现代电力电子技术的飞速发展&#xff0c;电网中增加了大量的非线性负载&#xff0c;如大容量变流设备、变频设备、开关电源等的广泛应用&#xff0c;导致大量谐波的产生&#xff0c;这些谐波使电网电压和电流波形发生畸变&#xff0c;使得电能质量日益下降。有源电力滤波器…

PAT甲级真题 1056 Mice and Rice (25分) C++实现(数组模拟分组淘汰赛,map记录重量排名,题意分析)

题目 Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse. First…

beautiful soup的用法

一、beautiful soup 是Python的一个HTML或XML的解析库。 他提供一个简单的、Python式的函数来处理导航、搜索、修改分析数等功能。它是一个工具箱&#xff0c;通过解析文档为用户提供需要抓取的数据&#xff0c;因为简单&#xff0c;所以不需要多少代码就可以写出一个完整的应用…

java中set和ge什么么意思,java的Collection和Map详解

java的Collection和Map详解线性表&#xff0c;链表&#xff0c;哈希表是常用的数据结构&#xff0c;在进行Java开发时&#xff0c;JDK已经为我们提供了一系列相应的类来实现基本的数据结构。这些类均在java.util包中。本文试图通过简单的描述&#xff0c;向读者阐述各个类的作用…

php用户管理员登录代码,标识用户登录状态

数据库think_user表新加一个status字段,用户登录后更改数据库字段来表示登录与在线状态用户登陆成功后添加如下代码:存入session,修改members()方法,代码如下:<?php Session::start();if(isset($_SESSION[admin_name])){//session存在不用验证权限$user User::get([user_n…

AtCoder Regular Contest 095

AtCoder Regular Contest 095 C - Many Medians 题意&#xff1a; 给出&#xff4e;个数&#xff0c;求出去掉第&#xff49;个数之后所有数的中位数&#xff0c;保证&#xff4e;是偶数。\(n\le 200000\) 分析&#xff1a; 发现题目范围支持\(nlogn\)做法。 我们可以对这些数字…

PAT甲级真题 1057 Stack (30分) C++实现(单个multiset,维护中位数指针)

题目 Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed…